Celesta CRM Incident

Incident Report for Celesta Platform

Resolved

The issue has been fully resolved. We appreciate your patience and apologize for the inconvenience.
Posted Apr 09, 2026 - 15:56 UTC

Monitoring

We’ve implemented a fix and are currently monitoring the system to ensure stability.
Posted Apr 09, 2026 - 15:24 UTC

Update

Our investigation is ongoing, but we have determined that some transactions are stuck.
Actions being taken: Cleanup

Estimated time to resolution: Not available at this time

Current Impact: CRM, Fraud, Wallet, and Payment services are affected.
Posted Apr 09, 2026 - 15:11 UTC

Investigating

Payment Timeouts

We have identified the issue and are actively working on a resolution.

Current Impact:

CRM, Fraud, Wallet, and Payment services are affected
Some payments are timing out

Actions in Progress: Rolling back recent changes to restore stability
Posted Apr 09, 2026 - 14:50 UTC
This incident affected: Celesta (CRM).